MSSP National Cylance Partner - (855) 500-4295 - Sales@kittyhawksecurity.com

Windows (32-bit or 64-bit)

• Windows XP SP3

• Windows Vista

• Windows 7

• Windows 8 and 8.1

• Windows 10

• Windows Server 2003 SP2

• Windows Server 2008 / 2008 R2

• Windows Server 2012 / 2012 R2

• Windows Server 2016

Mac OSX

• Mac OS X 10.9 (Mavericks)*

• Mac OS X 10.10 (Yosemite)*

• Mac OS X 10.11 (El Capitan)*

• Mac OS X 10.12 (Sierra)*

*Complements Apple’s built-in XProtect

Linux

• Red Hat Enterprise Linux / CentOS 6.6 — 32-bit and 64-bit

• Red Hat Enterprise Linux / CentOS 6.7 — 32-bit and 64-bit

• Red Hat Enterprise Linux / CentOS 6.8 — 32-bit and 64-bit

• Red Hat Enterprise Linux / CentOS 7.0 — 64-bit

• Red Hat Enterprise Linux / CentOS 7.1 — 64-bit

• Red Hat Enterprise Linux / CentOS 7.2 — 64-bit

• Red Hat Enterprise Linux / CentOS 7.3 — 64-bit

• 2GB Memory

• 500MB Available Disk Space

• Microsoft .NET Framework 3.5 SP1

• Internet browser

• Internet connection to register product

• Local admin rights to install software

• 2GB Memory

• 500MB Available Disk Space

• Internet browser

• Internet connection to register product

• Local admin rights to install software

2GB Memory

• 500MB Available Disk Space

• Internet browser

• Internet connection to register product •

Local admin rights to install software


Support for macOS High Sierra (10.13)

macOS High Sierra (10.13) includes a new security feature that requires users to approve new third-party kernel extensions.

 

Support for Windows 10 Anniversary Update

Microsoft Windows 10 Anniversary Update is supported with Agent version 1400 or higher. Microsoft Windows 10 Device Guard and Credential Guard are supported with Agent version 1410 or higher. Microsoft has also introduced a version of Windows Subsystem for Linux (WSL) in the Windows 10 Anniversary Update. WSL lets users run a bash shell on Ubuntu on Windows and has been received very positively by the developer community. WSL is disabled by default and Microsoft is likely to introduce more features before it becomes generally available. Cylance is following these updates and will introduce necessary controls for WSL when it becomes mainstream. Until then, Cylance recommends disabling this feature.

 

Support for Microsoft Windows 10 Creators Update (Windows 10 version 1703)

Microsoft Windows 10 Creators Update (v1703) is supported with Agent version 1440 or higher. Note: Windows 10 Creators Update has the same known issues as the Windows 10 Anniversary Update.

 

Support for Microsoft Windows 10 Fall Creators Update (Windows 10 version 1709 - Redstone 3)

Microsoft Windows 10 Fall Creators Update (v1709) is supported with Agent version 1440 or higher. Scanning hydrated files from Microsoft OneDrive is not supported. Enabling Windows Defender Device Guard Code Integrity will cause Modern Apps to fail with error 0xC000047E when Memory Protection or Script Control is enabled. Cylance is currently investigating this issue. Note: Windows 10 Fall Creators Update has the same known issues as the Windows 10 Anniversary Update.

CylancePROTECT does not support scanning hydrated files from Microsoft OneDrive. Cylance is working on adding support for files hydrated on the device from OneDrive and expect this feature to be added in an upcoming release.

.NET Framework 4 Client Profile

Agent version 1400 will show as offline if the device is using Microsoft .NET Framework 4 Client Profile. To resolve this issue, install the full version of .NET 4.0 (or higher).

Checking the .NET version using the command-line will display .NET Framework 4 Client Profile as v4. The full version of .NET 4.0 will display v4.0.xxxxx. Checking Uninstall Programs (aka Programs and Features), the version will display as .NET Framework 4 Client Profile. With Verbose logs (aka Debug or All) enabled, the following information will appear in the logs: "Could not load file or assembly 'System.WorkflowServices".

TLS 1.2

Agent version 1420 (Windows) or higher supports using TLS 1.2. Agent version 1450 (macOS) or higher supports using TLS 1.2. Agent version 1460 (Linux) or higher supports using TLS 1.2 TLS 1.2 support requires a .NET Framework version of 4.5 or higher to be installed. If .NET Framework 4.5 or higher is not installed the agent will fallback to using TLS 1.0.